AviUtlで動画をMP4で出力する方法

AviUtlで動画をMP4で出力する方法

AviUtlは初期状態では動画をMP4ファイルとして出力することができません。この記事では動画をMP4出力するために必要なプラグインとそのインストール方法、実際にAviUtlで動画をMP4出力する方法を解説します。

目次

拡張x264出力(GUI)Exのインストール

まずは下記サイト様からプラグイン「x264guiEx」をダウンロードします。予めAviUtlは終了させておいてください。

rigayaの日記兼メモ帳

aviutl_mp4formed1

ページ右側のバーにある「x264guiEx 2.xx」をクリックします。この記事執筆時点では2.xxが最新版ですがもし3.xxが出ていればそちらをダウンロードして下さい。

aviutl_mp4formed2

上記赤枠部分をクリックして「x264guiEx」をダウンロードします。

aviutl_mp4formed3

ダウンロードしたフォルダを解凍して「auo_setup.exe」をダブルクリックなどで実行します。ダウンロード先は「Aviutl.exe」のあるフォルダにして下さい。

ダウンロード場所を間違えないように下記画像をご参照下さい。

aviutl_mp4formed4

上記の方法でインストール場所を表示させたら「Ctrl+C」などでコピーして、先ほどのインストール画面に貼り付け、「次へ」をクリックします。

aviutl_mp4formed5

しばらく時間がかかりますが、上記画面になったらインストールは完了です。

拡張x264出力(GUI)Exの動作確認

まずはテストとしてAviUtlに適当な動画を読み込ませましょう。

aviutl_mp4formed6

「ファイル」→「プラグイン出力」の欄に「拡張x264出力(GUI)Ex」があるか確認します。

aviutl_mp4formed7

「拡張x264出力(GUI)Ex」をクリックすると上記画面が開きます。「ビデオ圧縮」をクリックして設定画面を開きましょう。

aviutl_mp4formed8

設定画面が開きます。まずは赤枠部分のファイルが実際に存在することを確認しましょう。ファイル名の横にある「…」ボタンをクリックするとそのファイルの場所が開きます。

aviutl_mp4formed9

ファイルが実際にある場合は上記のようにファイルが表示されます。

aviutl_mp4formed10

次に「プロファイル」をクリックして問題なく表示されるか確認しましょう。ここまでで問題がなければインストールは正常に完了しています。

MP4出力のやり方

それでは実際に拡張x264出力(GUI)Exを使って動画をMP4で出力してみましょう。

aviutl_mp4formed11

先ほどの「プロファイル」から何でもいいので1つ選択します。プロファイルとは設定を格納したもので、予め「ニコニコ動画用」や「youtube用」などの基本設定が格納されていて、選択することでその設定を呼び出すことができます。

たとえばニコニコ動画にアップロード可能な上限ファイルサイズは一般会員で40MB、プレミアム会員で100MBとなっていますが、プロファイルで「ニコ動プレミアム」を選択するだけで自動的に上限ファイルサイズを100MBに設定してくれます。

細かく設定したい場合はここから各項目をいじればいいのですが今回はこのまま出力します。

aviutl_mp4formed12

プロファイルを選択したら「OK」をクリックして設定画面を閉じ、動画の保存先を選んで「保存」をクリックすると出力が開始されます。

aviutl_mp4formed13

今回の場合「.avi」の動画を「MP4」に変換していますがこの処理をエンコードと言います。動画の長さや編集の複雑さ、パソコンの性能にもよりますが時間がかかるものなのでおわるまでゆっくり待ちましょう。

このエントリーをはてなブックマークに追加
カテゴリー: AviUtl 投稿日:

AviUtlで動画をMP4で出力する方法」への72件のフィードバック

  1. 名無し

    ありがとうございます
    分かりやすい説明でPCに慣れていない私でも
    ちゃんと出来ました
    ありがとうございます

    返信
  2. まこと

    auo [info]: x264guiEx 2.51 / Windows 7 x64 (7601) / Intel Celeron(R) B810 @ 1.60GHz (2C/2T)
    auo [info]: converting YUY2 -> nv12p, using SSE2
    auo [info]: x264 version: 0.152.2851 ba24899 –bit-depth=8 –chroma-format=all
    auo [info]: x264 options…
    –preset fast –crf 18 –qpstep 12 –qcomp 0.85 –chroma-qp-offset -2 –rc-lookahead 40 –aq-strength 0.75 –keyint 300
    –min-keyint 4 –deblock 1:1 –colormatrix bt709 –frames 5614 –input-res 1280×720 –input-csp nv12 –fps 30/1 -o
    “C:\Users\○○\Desktop\2017年7月13日.mp4” “-”
    mp4 [error]: cannot open output file `C:\Users\○○\Desktop\2017年7月13日.mp4′.
    x264 [error]: could not open output file `C:\Users\○○\Desktop\2017年7月13日.mp4′
    auo [error]: x264が予期せず途中終了しました。x264に不正なパラメータ(オプション)が渡された可能性があります。
    auo [info]: CPU使用率: Aviutl: 46.67% / x264: 0.00%
    auo [info]: x264エンコード時間 : 0時間 0分 0.1秒
    auo [info]: 総エンコード時間 : 0時間 0分 1.2秒

    返信
  3. SAITAMA KOBATON

    aviutlに使い慣れてきたので、このページは参考になりました。
    これで益々使いやすくなったのでうれしいです。ありがとうございました。

    返信
  4. バイヤ

    失礼します。動画編集でいきなり躓いてしまい
    書き込みをさせてもらっています。

    「ビデオ圧縮」をクリックして設定画面を開き
    プロファイルを選択し
    ニコ動、Twitter、youtubeを選んだ際
    エラーが出てしまいます。(PSPやその他はできました。)
    「設定ファイルオープンに失敗しました。
    このファイルを削除しますか?」と表示されます。
    どこをいじれば正常に戻るか教えていただけませんか?

    返信
  5. につく/nick

    出力すると、下のようなエラーが出ます

    auo [error]: mux後ファイルが見つかりませんでした。
    auo [error]: L-SMASH muxer でのmuxに失敗しました。
    auo [error]: muxのコマンドラインは…
    auo [error]: “.\exe_files\muxer.exe” –file-format m4v -i “C:\Users\にっく\Documents\aa.mp4”?fps=60/1 –file-format m4a -i “C:\Users\にっく\Documents\aa.tmp.wav” –optimize-pd -o “C:\Users\にっく\Documents\aa_muxout.mp4”
    L-SMASH muxer [error]: iTunes MP4 muxing mode
    L-SMASH muxer [error]: Track 1: H.264 Advanced Video Coding
    L-SMASH muxer [error]: Error: the input seems Uncompressed Audio, at present available only for QuickTime file format.
    L-SMASH muxer [error]: Error: failed to open input files.
    auo [info]: 総エンコード時間 : 0時間 0分 0.8秒

    と出て、「ファイルの出力に失敗しました」と出ます
    どうしたらよいですか?

    返信
  6. 匿名

    avitulの圧縮するを押した後に出てくる設定ページがaviの後ろに出てくるためそのページを押しても開けません

    返信
  7. トントン

    aviutlでMP4出力するとなぜか、画面は映らず音声だけエンコードされて完成されます。
    何回かエンコードしたときはavi出力してから、だったんですけどそれをMP4出力をいきなりやる。に変更しました。何か問題でもあったんでしょうか?

    返信
    1. 管理人 投稿作成者

      トントン様

      私の環境ではいきなりmp4出力しても問題は起きていませんので、いきなりmp4で出力すること自体は問題ないようです。
      ただ、昔低スペックPCで出力した際、画像の色彩や音声がおかしくなったことがあり、その時は一度avi出力してからそれを取り込んでmp4出力するとうまくいきました。
      私のケースについては、その動画は再生時間が長くオブジェクトが多かったためスペック不足のせいかと推測したのですが、トントン様のケースとは症状が異なるためなんとも言えません。

      返信
  8. せいりゅう

    なんかさいごまでいったらえらーがでるんですけどー
    出力が終わりそうになったらエラーになっていてです

    返信
  9. ばーと

    エンコ無事に完了したのですが、ツイッターに投稿した後再生してみると
    ちょくちょく「音声は聞こえるが画面が一秒ほど黒くなる」時があります
    エンコード方法に問題があるのでしょうか?
    プラグイン出力で「拡張x264出力(GUI)Ex」を選んだ後は「ファイルの種類」の項目をmp4にする以外すべて初期設定です

    返信
    1. 管理人 投稿作成者

      ばーと様

      私もファイルの種類をmp4にして出力したことが何度かありますが、そういった症状が起きたことはありません。
      編集内容で黒い画面を挟んでしまっているか、もしかするとですがハードウェアのスペック不足で正常にエンコードできなかったという可能性も考えられます。

      返信
  10. さいこ

    質問でも何でもないですが、コメント欄含め色々有益な情報を得ることが出来ました!
    ありがとうございます!

    返信
  11. k

    編集中に突然落ちてしまい、再度編集しようとファイルを開いたら、プライグン後のフォルダからアイコンが消えてしまっている。。。

    返信
  12. Smithk314

    You really make it seem so easy with your presentation but I find this topic to be really something which I think I would never understand. It seems too complicated and extremely broad for me. I’m looking forward for your next post, I’ll try to get the hang of it! bededbagcgaadbac

    返信
  13. 匿名

    x264guiex.iniが存在しないと出ます。
    インストールも完了確認し、再度インストールなどをしようとすると
    存在しないといっていたくせに
    iniデータがすでにあります。 上書きしますか?
    とでる 解決策はないものか・・・

    返信
    1. 管理人 投稿作成者

      一度x264guiex.iniファイルが存在するかどうか確認してみてください。
      正常にインストールした状態であればそのファイルは「AviUtl」フォルダ内の「plugins」フォルダ内に存在するはずです。

      返信
  14. クロワッサン

    サイトからダウンロードしたファイルを解凍してその中にあるauo_setup.exeを実行したのですが、インストール画面が表示されず黒い画面が消えてしまい、aviutlにもプラグインがインストールされていませんでした。何が原因でしょうか?

    返信
    1. 管理人 投稿作成者

      クロワッサン様

      はっきりとした原因はわかりませんがインストールに失敗しているものと思われます。
      もう一度インストールし直してみる、それでもダメなら別の解凍ソフトを使って解凍してみる、などをお試し下さい。
      特に、インストール先が間違いなく「Aviutl.exe」のあるフォルダになっているかどうかご確認下さい。

      返信
  15. クロワッサン

    ファイルを解凍してauo_setup.exeを実行した後、黒い画面が消えてもインストール画面が表示されず、再度実行しても「4.5.2 言語パックは 既にインストールされています」と表示されすぐに消えてしまいます。 何が原因なのでしょうか?

    返信
  16. イービルアイ

    出力すると動画がかくかくします
    解決策を教えていただけないでしょうか

    返信
    1. 管理人 投稿作成者

      イービルアイ様

      ご使用の環境や作成した動画の編集内容がわからないため断定はできませんが、ハードウェアのスペック不足が考えられます。
      私も以前CPU2.3GHzの2コア、メモリ4GB、GPUなしのwindows7で無理矢理出力していたら動画が正常に出力されないことがありました。

      エンコード(出力)処理は動画編集の中でも最もスペックを要求される処理です。エンコード中にブラウザなど他のソフトを開くと、コンピュータの処理能力が不足して動画が正常に出力されないことがありますので、エンコード中は極力他のプログラムを閉じてPCへの負荷を減らしてみてください。
      それでも解決しない場合は動画の長さを短くしたり編集内容を簡単にしたり、どうしてもPCスペックが不足していると思われる場合はGPU(グラフィックボード)やメモリを見直す必要があるかもしれません。(ハードの性能が十分と考えられる場合には他に原因が考えられますので慎重にご判断下さい)

      返信
  17. キリガ

    1度質問したんですけど反映されてないっぽいので質問します、ビデオ圧縮しようとして設定画面開くんですけど、赤い枠の中にあるはずのファイルがありません、どうすればいいでしょうか?

    返信
    1. 管理人 投稿作成者

      キリガ様

      画像赤枠内のフォルダがない場合はインストールに失敗していると思われます。
      お手数ですが拡張x264出力(GUI)Exを再インストールしてみてください。

      返信
      1. キリガ

        ありがとうございます、最後にもう1つわからないことがあるので質問します、最後のこうていまでいったんですけどエンコードが終わると動画が0,1秒だったりすごく短くなります、どうすればいいでしょうか?

        返信
  18. キリガ

    ビデオ圧縮を押した後赤い枠の中にフォルダがありません、横の、、、を押してもフォルダが出てきません、どうすればいいでしょうか?

    返信
  19. you

    出力すると作った動画が最初の1秒で終わってしまいます。
    どうしたらよいでしょうか。

    返信
    1. 管理人 投稿作成者

      you様

      AviUtlには指定した範囲だけを動画として出力する機能があります。
      aviutl_mp4encod5

      上記画像の右下の矢印部分が出力する範囲を指定するボタンなのですが、何かの拍子にこのボタンを押してしまうと本体編集であろうと拡張編集であろうと動画を一部分だけ指定して出力してしまいます。
      全部分が選択されていれば上記画像下部の青いバーが全て青色になっているのですが、指定されていない部分があると上記画像のように一部が白色になります。この場合白い部分は指定範囲に含まれておらず、動画として出力されません。
      指定範囲を解除するにはメインウィンドウ上で右クリック → 「範囲選択の削除」をクリックします。

      返信
    1. 管理人 投稿作成者

      ぎん様

      「x264guiEx」のファイルの解凍、またはインストールに失敗している可能性が考えられます。
      もう一度ダウンロード、インストールし直してみたり、別の解凍ソフトを使ってみてください。

      返信
  20. やえくん

    初心者です。拡張編集をした後、x264出力を行おうとしたのですがどうもエラーが出てしまい出来ません。他に方法があるのでしょうか?

    返信
    1. 管理人 投稿作成者

      やえくん様

      他の動画形式でファイルを出力することは可能ですが、例えばAviUtlにデフォルトで付いている.avi形式で出力すると無圧縮の、非常に容量の重い動画となってしまいます。
      エラーメッセージをそのままGoogle検索するだけでもエラーの解決法が出てくる場合がありますので、なるべくならエラーの解消法を探してみることをおすすめします。

      返信
  21. 努武

    すみません、初心者です。
    正しい場所にダウンロードしてautosetupを起動させると
    .\setup\setup.iniの記述が正しくありません。インストールを続行できません。
    もう一度ダウンロードしてやり直して下さい。
    と、でます。
    何度ダウンロードし直しても同じ結果です。
    何が電原因でしょうか?
    お教えいただければ助かりますm(_ _”m)

    返信
    1. 管理人 投稿作成者

      努武様

      同様の質問がプラグイン制作者様のブログでも1件のみですが挙がっていました。
      詳しい原因は不明とのことですが、「.NET Framework 4.x」がインストールされていないと判定された時に、「.NET Framework 4.0をダウンロードしている」ところでエラーが発生しているようです。
      (OS次第ですが、事例の方はWindows7を使用しており、Windows7では「.NET Framework 4.x」は自動的にインストールされるはずです)

      回避策として「auo_setup」ではなく、同階層の「setup」フォルダの中にある「auoSetup」をダブルクリックして実行してみてください、とのことです。

      返信
  22. 匿名

    失礼します。インストール中に「最新のQuickTimeバージョン情報取得に失敗しました。」と出てインストール失敗してしまうのですが、解決方法をご教授いただけますでしょうか?
    OSはWindows8です

    返信
    1. 管理人 投稿作成者

      おっしゃられている通りの問題が発生していたようです。
      拡張x264出力(GUI)Exの新しいバージョン(2.35v2)で修正されたようですので、最新バージョンをお試し下さい。

      返信
  23. 123

    お力お貸しください、素人です
    10分ほどの動画を作っているのですが、最後にmux後ファイルが小さすぎます。とでて出力が失敗します。
    x264guiExの設定で上限ファイルサイズなどを変えれば良いのでしょうか?ファイルビットレートなどはビットレート計算機で計算して反映させているのですが・・・。

    返信
    1. 管理人 投稿作成者

      123様

      同様の問題が発生したことはないので色々調べてみたのですが、原因を特定するのは難しそうです。
      そのため対処療法的になってしまうのですが、まずは他の動画を出力した場合でも同様のエラーが発生するかどうか確認してみてください。同様の症状が起きるようでしたら「x264guiEx」が正常に機能していない可能性があるため、再インストールしてみるのが良いかと思います。
      他の動画は正常に出力できる場合は該当動画のプロジェクトファイルが破損している場合も考えられるため、オブジェクトをエクスポートして新しいプロジェクトファイルにインポートし、出力してみるとうまくいくかもしれません。
      方法については下記記事の「編集したオブジェクトを保存する方法」をご参照下さい。

      AviUtlの編集内容を保存する方法

      もし映像ファイル、音声ファイル片方だけなら正常に出力できるのであれば、それぞれ別で出力したあとAviUtlの編集画面で再び合わせて出力してみることでうまくいく可能性もあります。
      その場合、最終手段としてAviUtlで出力した映像ファイルと音声ファイルをWindows Live ムービーメーカーで合成して出力するという方法もあります。

      返信
  24. achineil

    mp4が読み込まれない事象で、
    コンテナがmp4だったが中身は実はmkvファイルでした ってことがありました。

    動画を再生する分には問題なく実行できますが、AviUtlに読み込ませようとするとエラーが出てしまう。
    l-smashやx264guiExのインストールは正常にできているし、サンプルのmp4の読み込みはできたので、あれ、おかしいなあ
    と思って何となしにmkvに書き換えたところ、すんなりと読み込むことができました。

    もし何を試しても読み込めねえよ! という方がいらっしゃったら参考にしてください。

    返信
    1. 管理人 投稿作成者

      achineil様

      参考になるコメント誠にありがとうございます。
      mp4ファイルが読み込めないという報告は複数あったのですが、中身が別形式だったというパターンは想定できませんでした。
      重ねてお礼申し上げます。

      返信
  25. チビ

    何度やってもうまくいかないのですが原因がわからないので質問させてください。

    mp4出力の為、x264guiExの最新のものをインストールし、フォルダの指定もキチンときているのに、出力プラグインに表示が出てきません。

    何度も何度も試して、ダウンロードからやり直したり、試行錯誤したのですが、それでも表示されません。

    何が原因でしょうか。

    返信
    1. 管理人 投稿作成者

      チビ様

      申し訳ないのですが私にも原因がわかりかねます。
      出力プラグインに表示が出てこないということはインストールがうまくいっていないのだとは思いますが…。

      AviUtlを起動して「その他」→「出力プラグイン情報」で「拡張 x264 出力(GUI) Ex (x264guiEx) 2.xx by rigaya (x264guiEx.auo )」が表示されているかどうか確認してみてください。

      aviutl-mp4encod_a1

      aviutl-mp4encod_a2

      上記のように表示されていないようであれば拡張x264出力(GUI)Exのインストールが正常に完了していません。

      返信
  26. ゆーしー

    初めたばかりのド素人で大変恐縮です。お窺いしたい点が3点ほどあります。

    1. 拡張編集で「新規作成」を押し動画サイズを入力するのですが、これは一度のみしか入力出来ずそのままどのオブジェクトも最初に指定したサイズにしか出来ないのでしょうか?動画サイズがバラバラで黒い余白が出来てしまうのです。これは拡大などして余白を埋めサイズを揃えるしか方法がないのでしょうか?

    2. 拡張編集で編集したままx264出力する方法でやっておりますが、拡張編集したものをaviutlに読み込むというような方法はありますか?また、出力する際にaviutl本体に読み込む必要がありますでしょうか?

    3. 拡張編集の「新規作成」からサイズを512×384に指定し、aviutl本体の「設定」でサイズを1280×720にしているのですが、この場合やはり出力に時間は通常よりかかるものなのでしょうか?

    ホントに雑多な文面で大変申し訳ございません、管理人様。
    windows movie maker2.6がメモリ不足で編集出来なくなってしまい今回aviutlを使い初めていろいろ講座動画も拝見したのですがそれでも分からないことだらけで…

    お力添えいただけると幸いです。よろしくお願い致します。

    返信
    1. 管理人 投稿作成者

      ゆーしー様

      1.「新規作成」で設定するのはオブジェクト全体(その動画自体)のサイズで、各オブジェクトのサイズは「拡大率」という項目で調整可能です。余白に関しては各オブジェクトの大きさや場所を調整して整えるしかないかと思います。

      2.拡張編集で行った編集内容を保存して読み込む、という意味でしたら「ファイル」→「編集プロジェクトを保存」→保存した編集プログラムをAviUtlにドラッグ&ドロップで可能です。出力する際は当然本体に読み込む必要がありますが…申し訳ありません、私が質問の意味を正確に捉えられていないかもしれません。

      3.サイズを変更しているだけですので出力にかかる時間は変わらないかと思います。最終的にサイズを1280×720にするのでしたら「新規プロジェクトの作成」の時点でサイズを1280×720に指定してしまえば良いかと思いますが、何かしら不都合があるようでしたらその方法でも問題ないと思います。

      返信
  27. ひろひろ

    お力をお借りしたく伺いました。
    mov形式のムービーをMP4へ変換するとログの最後で

    auo [error]:L-SMASH remuxer の実行に失敗しました。

    結果、MP4ファイルに音声が入っていません。
    何が原因だと思われますか?
    OS いまだに「Xp」です。
    x264guiExは、2.34及び2.20v3のsetupが走らないので2.12v3にてインストールしてます。

    返信
    1. 管理人 投稿作成者

      ひろひろ様

      おっしゃられているようにやはりOSやプラグインのバージョンが古いことが引っかかります。
      AviUtlのように本体にいくつものプラグインを取り込んで使うプログラムでは、環境によって特定のプラグインの特定のバージョンが正常に動作しなかったり、本体のバージョンを更新した際に古いプラグインが正常に機能しなくなったりといったことは十分ありえます。

      逆に本体をダウングレードすると正常に動作する場合もあるため、本体の過去のバージョンをいくつか試してみると噛み合ってくれるかもしれません。

      返信
      1. ひろひろ

        返信ありがとうございます。
        やはりOSがねっくですよね~
        Xpもそろそろ潮時と考えているので環境整備してからまたトライしてみようと思います。
        またつまづいたら伺います。

        返信
        1. 管理人 投稿作成者

          ひろひろ様

          大したお役に立てず申し訳ございません。
          私にわかることでしたら出来る限りお答えしますので、また気兼ねなくご相談下さい。

          返信
  28. ~かゑで~

    Aviで出力してもyoutubeでは長い時間待たせておいて投稿失敗してて、困ってました。
    ですが、MP4で出力すると投稿できました。ありがとうございました。

    返信
    1. 管理人 投稿作成者

      ~かゑで~様

      お役に立てたようで何よりです。
      .aviの動画は無圧縮のためファイルサイズが非常に大きくなってしまうようですね。
      以前間違って.avi出力してしまい、SSDの容量を大きく食ってしまったことがあります^^;

      返信
  29. haruruchan

    ハイビジョンムービーのメーカーの動画編集機能(出力は.mbt)に不満があり、Aviutlで編集しようとしています。.mbt出力した動画編集をAviutlで読み込み.mp4ファイルを作り、tsMuxerGUIでブルーレイフォルダーを作り、ImgBurnでそのフォルダーからイメージファイルを作りディスクに焼いています。.mbt出力した動画編集をAviutlには正しく読み込んでいるのですが、出来たディスクはD-B305K(東芝)、BDP-S190(ソニー)のブルーレイ装置では正しく再生できません。試行錯誤して、その原因はtsMuxerGUIがブルーレイフォルダーを作るときBDMVフォルダーとCERTIFICATEフォルダーが作成されますが、BDMVに余分なファイルがあるのが分かりました。01900.clpiと01900.mplsそれに01900.m2tsです。それらを削除すると正しく再生できます。どこか間違っているのでしょうか。

    返信
    1. 管理人 投稿作成者

      haruruchan様

      コメント頂きありがとうございます。
      私はAviUtlをネットで再生するための動画を編集する用途でしか使っておらず、ブルーレイプレーヤーなどの家電で再生するための動画や.mbt出力、動画のオーサリングなどの知識には欠けているためお答えすることができません。
      お役に立てず申し訳ありません。

      返信
  30. すみません、インストールした後にビデオ圧縮を押して設定画面を開いたら、赤い枠で囲まれている部分のファイルが表示されていません……。何が原因でしょうか?

    返信
    1. 管理人 投稿作成者

      雨様

      該当ファイルのダウンロード、またはインストールに失敗してしまった可能性が考えられます。
      一度「拡張x264出力(GUI)Ex」をアンインストールし、もう一度インストールし直してみて下さい。

      返信
    1. 管理人 投稿作成者

      金魚様

      コメント頂きありがとうございます。
      微力ながらお役に立つことができたようで何よりです。

      返信
  31. 拡張x264 出力を開始してすぐに、黄色の文字で
    「音声の長さが動画の長さと大きく異なるようです。
     これが意図したものでない場合、音声が正常に出力されていないかもしれません。
     この問題は圧縮音声をソースとして使用すると発生することがあります。
     一度音声をデコードし、「音声読み込み」から無圧縮wavとして別に読み込むか、
     異なる入力プラグインを利用して読み込むといった方法を試してみてください。」
    と表示され、最後には出力失敗の表示がされます。
    この場合はデコードするべきだとわかっていますが、どのようにすればいいのでしょうか?
    音声は動画に合わせて長さを編集したので、長さはあっています

    返信
    1. 管理人 投稿作成者

      錬様

      コメント頂きありがとうございます。
      私は音声のデコードを行ったことがなく、方法についても詳しくないためお答えすることができません。
      お力になれず大変申し訳ございません。

      返信
    1. 管理人 投稿作成者

      るるる様

      コメントありがとうございます。
      お役に立てたようで何よりです。

      返信
  32. HIKARU

    拡張x264出力(GUI)Exで出力する時
    出力失敗と音声読み込み失敗などが出るんですかどうしたら正常に出力するには
    どうすれば良いんですか?手順を教えてください。

    返信
    1. 管理人 投稿作成者

      HIKARU様

      出力失敗の原因は多岐にわたるため、その情報だけで特定するのは申し訳ありませんが困難です。
      例えばですが、動画ファイルや音声ファイルの場所がプロジェクト作成時と異なる場所に移動されていたり、削除されてしまっていて読み込めない場合、
      オブジェクト数が多すぎたり、作成した動画ファイルのサイズが大きすぎて、出力にPCスペックが追い付いていない場合などが考えられます。

      エラーメッセージをそのままコピーしてGoogle検索にかけてみると対処法が見つかる場合もありますのでそちらもお試し下さい。

      返信
  33. れれれ

    rigaya様のページにいってダウンロードさせていただきたいのですが、リンク先がエラーになるのですが、どのようにさせていただけばダウンロードできますでしょうか。

    返信
    1. 管理人 投稿作成者

      れれれ様

      今rigaya様のページからもう一度ダウンロードしてみたのですが、私の場合は問題なくリンク先へジャンプし、ダウンロードを完了できました。
      一時的にダウンロードできない状態となっていたのか、そうでなければ れれれ様の環境に何かしらの問題があるのかもしれません。

      返信
    1. 管理人 投稿作成者

      あんこもち様

      拡張x264出力(GUI)Exによる出力を行う画面で、「保存」を押す前に保存先を選択することができます。
      動画はここで選択した場所に保存されます。

      返信
  34. アース

    やっとMP4のエンコードが終わり出来上がった動画を見てみると、最初の部分が少し途切れており、最後の部分が真っ暗の状態が余分にできていました。しっかり「最後のオブジェクト位置を最終フレーム」も押しました。この解決策を教えて頂けると幸いです。

    返信
    1. 管理人 投稿作成者

      アース様

      編集画面を見ていないのでハッキリとは申し上げられませんが、AviUtlには指定した範囲だけを出力するという機能があります。
      最初の部分がまるまる途切れてしまうのであれば、出力範囲が動画の途中からに設定されてしまっている場合が考えられます。

      真っ暗の状態が余分にできてしまう件は動画の最後の部分に映像オブジェクトが置かれておらず、音声オブジェクトだけの部分、または何のオブジェクトも置かれていない部分ができてしまっている場合が考えられます。
      例えば下記画像の状態で「最後のオブジェクト位置を最終フレーム」に設定すると、動画の最初と最後の時間帯(矢印部分)は画面は真っ暗で音声のみとなります。

      aviutl_mp4encod14

      他には「最後のオブジェクト位置を最終フレーム」を設定した後に、最後のオブジェクトを時間軸手前に移動したり、消去してしまった場合は最終フレーム位置がそのオブジェクトのあった位置のままになってしまいます。
      最後に真っ暗で無音の余分な部分ができてしまったことは私も経験があり、これが原因でした。

      十全な解答ができず申し訳ありません。
      参考にしていただければ幸いです。

      返信
  35. みかん

    youtubeのアップロード時間が長すぎて困ってました。
    本当にありがとうございます!助かりました!

    返信

コメントを残す

頂いたコメントは一読した後表示させて頂いております。
反映まで数日かかる場合もございますがご了承下さい。